Helpdesk Inaccessible

Incident Report for Trinity High School

Resolved

We have not received official confirmation, but the helpdesk is back online. The presumption is that the issue has been fixed.
Posted Oct 17, 2025 - 08:29 EDT

Update

From Happyfox: "We’ve escalated the reported issue to our backend team, and they’re working on it with top priority. We’ll keep you posted and share updates at the earliest."
Posted Oct 17, 2025 - 08:25 EDT

Investigating

The helpdesk is currently inaccessible. They are working to resolve the issue.
Posted Oct 17, 2025 - 08:20 EDT
This incident affected: Websites (Helpdesk).