Email Delays

Incident Report for Trinity High School

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 11:19 EST

Monitoring

A fix has been implemented and they are monitoring the results. They believe the issue is resolved.
Posted Jan 30, 2026 - 10:24 EST

Investigating

There may be delays in receiving emails. They are aware and working to fix the problem.
Posted Jan 30, 2026 - 10:16 EST
This incident affected: Office 365 (Outlook).