Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 31, 2026 - 09:00 EST
Scheduled
The Schoology Operations Team will be performing scheduled database updates to enhance security, improve system performance, and ensure data integrity. During this maintenance window, all services will be temporarily unavailable during this four-hour maintenance window.
Posted Jan 26, 2026 - 13:21 EST
This scheduled maintenance affected: Websites (Rockspace).