PowerSchool Inaccessible

Incident Report for Trinity High School

Resolved

PowerSchool appears to be back online at this time. We have not heard from PowerSchool as to a root cause.
Posted Sep 12, 2025 - 08:43 EDT

Investigating

PowerSchool and PowerTeacher are currently inaccessible. A case has been opened with PowerSchool.
Posted Sep 12, 2025 - 08:14 EDT
This incident affected: Websites (PowerSchool SIS).