Amazon Web Services (AWS) Outage Affecting Many Sites

Incident Report for Trinity High School

Resolved

The AWS outage is still being mitigated, but PowerSchool now lists Schoology as fully functioning. We will close out this issue. Do be aware that you may experience issues with various apps and services online as Amazon works to resolve their server issues. At this time, we are not aware of any issues that are directly impacting Trinity's services.
Posted Oct 20, 2025 - 09:40 EDT

Investigating

Unfortunately, it looks as though there was some regression. PowerSchool now lists Schoology (Rockspace) as a "major outage" instead of just "degraded performance." They are continuing to work through the problems.
Posted Oct 20, 2025 - 08:21 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 07:56 EDT

Monitoring

Amazon Web Services (AWS), which powers many major websites and services, experienced a major outage overnight. They are still recovering. If you come across something that isn't working, it is likely caused by this. AWS is in the process of coming back up, but many things are still down or operating slowly.
Posted Oct 20, 2025 - 07:30 EDT
This incident affected: Websites (Rockspace).