PowerSchool has closed the incident and the system should now be functioning normally.
Posted Jan 06, 2026 - 12:45 EST
Monitoring
From PowerSchool: "A fix has been deployed to address the application outage issue within PowerSchool. We are currently monitoring the service to ensure stability and confirm that the issue has been fully resolved."
Posted Jan 06, 2026 - 10:30 EST
Investigating
From PowerSchool: "We are investigating the reports from few users that PowerSchool SIS is down. We are actively investigating the issue and coordinating with our third-party vendor to mitigate the impact. We will continue to provide regular updates as we progress towards a resolution."
Posted Jan 06, 2026 - 10:11 EST
This incident affected: Websites (PowerSchool SIS).