PowerSchool Issues

Incident Report for Trinity High School

Resolved

This incident has been resolved.
Posted Feb 03, 2026 - 14:49 EST

Monitoring

From PowerSchool: "A fix has been deployed by our Vendors to address the access issue within PowerSchool SIS and customer impact has been mitigated. We are currently monitoring the service to ensure stability and confirm that the issue has been fully resolved."
Posted Feb 03, 2026 - 14:49 EST

Identified

From PowerSchool: "The cause of the issue within PowerSchool SIS has been identified as being related to an issue with our networking vendor. We are actively coordinating with the vendor to implement a resolution and will continue to share updates as they become available."

Note: We are not seeing any issues here at Trinity, but be aware that it may yet affect us.
Posted Feb 03, 2026 - 13:51 EST

Investigating

From PowerSchool: "We are investigating reports of access issue within PowerSchool SIS. We are working diligently to mitigate the issue being reported and will continue to provide regular updates as we progress towards a resolution.."
Posted Feb 03, 2026 - 13:30 EST
This incident affected: Websites (PowerSchool SIS).