Rockspace Periodically Unavailable for Some Users

Incident Report for Trinity High School

Resolved

From Schoology: "We have deployed a fix that has resolved the issue, and the site is currently stable. We will continue to monitor the application availability to ensure consistent performance and critical functionality remains intact as expected."
Posted Sep 16, 2025 - 14:59 EDT

Identified

Schoology has acknowledged the issue, saying, "We’ve identified an issue where some users may experience intermittent errors when navigating in Schoology Learning. Re-loading the page may resolve the issue. We are investigating and We will continue to provide regular updates on our progress."
Posted Sep 16, 2025 - 14:21 EDT

Update

Refreshing the page may temporarily help with the issue.
Posted Sep 16, 2025 - 14:08 EDT

Investigating

Rockspace is periodically displaying a message from Schoology stating that it is temporarily unavailable. They are investigating the issue.
Posted Sep 16, 2025 - 14:06 EDT
This incident affected: Websites (Rockspace).