HappyFox reports that the incident has been resolved. The helpdesk should be fully functional once again. Thank you for your patience.
Posted Nov 21, 2025 - 10:19 EST
Monitoring
We have not received official word from HappyFox yet, but we are seeing the system back online and acting normally. We will continue to monitor as we awaiting word from the provider.
Posted Nov 21, 2025 - 10:15 EST
Update
From HappyFox: "We are investigating reports of errors from a subset of our accounts."
Posted Nov 21, 2025 - 10:07 EST
Investigating
We are experiencing issues with HappyFox, our helpdesk software. It may be inaccessible at times as they work on the issues. We are also seeing reports that Amazon Web Services (AWS, the service that went down about a month ago and affected hundreds of sites and services) may again be experiencing problems.